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Office of Administrative Hearings 

Rules Division 

Template Documentation 

The Rules Division within the Office of Administrative Hearings has created a Microsoft Word Macro 

Enabled Template that Rule Making Coordinators can use to facilitate the rule making process.  The OAH 

Agency Rules Template contains formatting styles and various utilities that will assist the coordinators as 

they draft and modify rules.  The Template was developed using Microsoft Word 2016 and should function 

property in Microsoft Word 2010 or higher. 

The template was developed to assist the Rule Making Coordinators create a document that adheres to the 

requirements set out in 26 NCAC 02C .0108 General Format Instructions.  Within the template, there are 

utilities that allow the coordinator to: pull a rule from the OAH website and insert it directly into your 

document; apply various formatting styles to the text within a document; insert auto text for the various 

Introductory Statements required for the submission of a rule; and various other functionality to make the 

process simpler. 

DOWNLOADING THE OAH AGENCY RULES TEMPLATE 

The OAH Agency Rules Template can be downloaded from the Rulemaking Coordinator Section in the 

Rules Division area of the OAH website (http://www.oah.state.nc.us/rules/).  To download the Template, 

you click on the “Rule Template” link.   

 

http://reports.oah.state.nc.us/ncac/title%2026%20-%20administrative%20hearings/chapter%2002%20-%20rules%20division/subchapter%20c/26%20ncac%2002c%20.0108.html
http://www.oah.state.nc.us/rules/
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After clicking the “Rule Template” link, Internet Explorer will prompt the user with the Open, Save, Save 

As Dialog box. (Testing was done using Internet Explorer, other Browsers may have slightly different 

prompts.) 

 

In the testing performed during the development of the Template, the easiest implementation of the 

Template was to save the template to the operator’s Desktop.  This can be accomplished by clicking the 

“Save As” option and then select Desktop and press the Save Button.  It is imperative that you leave the 

Template named “OAH Agency Rules Template.dotm”.  Various functionality within the Template 

requires the standardized naming. 

 

Once the Template has been saved to the Desktop, the operator should open the Template by Right 

Clicking on the Template Icon and selecting Open.  The first time the template is opened, the 

operator will be prompted to Enable the Template.  Once the Enable button has been pressed, the 

operator can close the Template. 

It is also possible to store the OAH Agency Rules Template in either the default Word User or Workgroup 

template locations.  This subject is not covered in this documentation but additional information about 

template locations is discussed in this blog posting which is applicable for Microsoft Word 2010 and 

higher: http://blogs.msmvps.com/wordmeister/2013/02/06/word-2013-templates-location-and-filenew/.  

The instructions in this document assume that the template is stored on the operator’s desktop. 

  

http://blogs.msmvps.com/wordmeister/2013/02/06/word-2013-templates-location-and-filenew/
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CREATING A DOCUMENT BASED ON THE OAH AGENCY RULES TEMPLATE 

To use the template, the operator should double click on the Template Icon on the Desktop.  A new 

document based on the template will be created.  An OAH tab will be added to the Microsoft Word Ribbon 

as can be seen below: 

 

The OAH Tab contains a number of groups.  In order to allow commonly used Word functionality to be 

performed without the operator having to select another Microsoft Office Ribbon tab, several standard 

Microsoft Office Groups have been included on this tab.  They are: 

 Clipboard 

 Font 

 Editing 

The buttons in these groups perform in exactly the same way as the buttons on the Standard Word Ribbon 

and will not be discussed further here except to mention that changes to existing rules should be made 

using the Underline and strikethrough font attributes – which are available in the Font Group.  Language 

added should be underlined and language removed from an existing rule should be struck through. 

FORMATTING GROUP 

 

OAH Rule Formatting Menu 
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The OAH Rule Formatting dropdown menu presents the operator with a visual display of the formatting 

options for each acceptable Rule Format.  The Menu is divided to categorize various Rule formatting 

options. For each line of the menu, the Style name is displayed in the left column and a description of the 

appropriate language or enumeration is displayed in the right column.  As you can see, the first three 

sections of the menu contain standard Rule options.  The forth section represents the various options to be 

included in the History Note Section and lastly there is a section that groups the less frequently used styles.  

To select the appropriate formatting, the operator should click the appropriate menu item.  The text 

currently selected in the document will be formatted according to the menu selection.  No text will be 

typed; this menu only applies formatting to the selected paragraph. 

Clear Formatting Button 

With many formatting options available in word it is sometimes helpful to “reset” the text and start over.  

The Clear Formatting options will remove all formatting from the selected text.  

Style Selector Combo Box 

As the operator becomes more familiar with the Rule Making formatting styles, it may be more efficient 

for the operator to select a paragraph style directly from the Style Selector Combo Box.  The operator may 

change the style of the currently selected text by clicking the drop down arrow and selecting the desire 

style. 

 

The dropdown shows the available Rule Making formatting styles.  In order for the styles to be correctly 

applied to the text, the operator should use only the two methods of applying styles provided on the 

OAH tab.  The Word styling functionality available on the "Home Tab" may result in underlined, 

stricken, bolded or italicized formatting being lost when a style is applied.   
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Paragraph Center Button 

This menu item simply centers the selected text. 

AUTO FORMAT GROUP 

 

When drafting new Rules, or making significant changes to existing Rules, the operator may find it helpful 

to use the features of the Auto Format Group to apply the appropriate formatting to text.  The right and 

left arrow buttons change the style of the paragraph containing the cursor to the next or previous style 

appropriate for the option selected.  For Example, if the operator is drafting a new Listing Style Rule, they 

type the first paragraph of the rule and press enter.  This creates a new paragraph with the “Paragraph” 

format.  This may be appropriate, but the operator may want to follow the paragraph with enumerated 

items.   

 

Instead of selecting the Item Style using options available in the Formatting Group, the operator may 

select the right arrow on the Listing line and the style will be changed. 

 

Additionally, they can use the right arrow again to format the text as a SubItem level. 

 

When the operator has finished with the SubItems, they can press the left arrow button on the listing line 

to return to the Item formatting style. 
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TEXT GROUP 

 

The Text Group provides functionality that will automatically insert language into the Rule document.  

Currently the Group offers menu choices that allow the operator to insert introductory language into a 

document or Insert the entirety of a Rule from the OAH website into the document. 

Proposed Intros and Permanent Intros Drop Down Menus 

The Proposed Intros and the Permanent Intros Drop Down menu items operator in exactly the same way.  

When the operator selects the appropriate menu time from the dropdown list, the introductory text will 

automatically be inserted at the top of the open document.  A blank paragraph is also inserted after the 

introductory language.  Both paragraphs will be styled according to the Rule Making Formatting 

guidelines. 
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Insert Rule Menu 

Copy and Paste often behaves unexpectedly in a Word document.  Styles may also complicate how the 

copy and paste function works and how it impacts the document.  For this reason, it is suggested that the 

operator always use the Insert Rule functions, when possible, and avoid the complications caused by copy 

and paste. 

The Insert Rule Menu currently has two options. The Insert Rule from Code option will retrieve the Rule(s) 

from the OAH website and insert it into the document. The Insert Rule from File will allow the operator 

to select a file stored on their computer or network and insert that document. 

Insert Rule from Code 

The Upon pressing the Insert Rule from Code Button, the operator will be presented with the Insert OAH 

Rule dialog box.   

 

The Insert Rule from Code window allows you to insert an individual rule, all rules contained in a 

SubChapter or all rules contained in a Chapter. The operator should type a valid Title, Chapter, 

SubChapter and Rule number and press the Retrieve Button.  To insert a specific Rule, the Title, Chapter, 

SubChapter (if applicable) and Rule number should be entered.  To insert a Chapter, the Title and Chapter 

information must be entered.  To insert a SubChapter, the Title, Chapter and SubChapter fields must be 

filled. If the document exists, the text of the currently published rule(s) in the NC Administrative Code 

stored on the OAH website will be inserted into the document. The Operator should note that Title and 

Chapter numbers that are only one digit, must be preceded by a zero. 

IMPORTANT: The operator must be aware of any ongoing Rule Making that is in process for the 

Rule being amended.  The Insert Rule function inserts the text currently published in 

the NC Administrative Code.  If the Rule in a modified format is pending Rules 

Review Commission action or Legislative Review, the text of that version of the rule 

will not be inserted. 
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Insert Rule from File 

The Upon pressing the Insert Rule from File Button, the operator will be presented with the Insert File 

dialog box.  The operator may then navigate to the appropriate location and the selected file will be 

inserted. 

 

 

UTILITIES GROUP 

 

OAH Rule Making guidelines do not allow agencies to submit Rules that contain Auto Numbered 

enumerated lists or Microsoft Word Revision Marks (Tracking).  While we understand that these features 

can be beneficial during the Rule Drafting process, they should be removed prior to submitting your Rule 

to OAH. 

Remove AutoNumber Button 

Microsoft Words Auto Number feature automatically alters the indention level and the wrapping structure 

of the underlining text.  For this reason, when a document is created or opened linked to the OAH Agency 

Rules Template, the AutoNumber feature in Word is disabled.  Rules that were already in the Rule Making 

process prior to the introduction of the OAH Agency Rules Template may contain AutoNumbered lists.  

For this reason, a feature has been included on the tollbar that will convert AutoNumbered list to standard 

enumerated text.  Once this option has been selected, there is not a utility to revert the text back to an 

AutoNumber format. 

Tracking To Text Button 

Microsoft Words Revision tools can be very useful during the agency Rule Drafting process.  Using 

Revision Marks (“Tracking”) can enable staff within the agency to coordinate on the modifications to the 

Rule and review when changes were made and by whom.  They do make editorial changes more difficult 

as documents from various agencies are pulled together by the OAH Rules Division.  For this reason, the 

OAH Rules do not allow “Tracking” to be included in submitted documents. 
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Having realized the advantages that “Tracking” may provide for agencies, a feature has been provided 

that will convert “Tracking” to Underlining and Strikethrough font attributes in the document.  Please note 

that once “Tracking” has been converted to text the editorial information regarding when changes were 

made and by whom will be lost from the document. 

NOTE: There can be a great deal of complexity in documents containing “Tracking”, therefore, it is 

recommended that after running this utility the agency staff carefully review the document to 

ensure that the revisions are accurately represented. 

Text to Tracking Button 

When Rules are returned to the agency by OAH, revision marks will be shown as underlining and 

strikethrough.  The Text to Tracking Button will convert the underlining and strikethrough in a document 

back into Microsoft Word Revision Marks (“Tracking”).  Please keep in mind that the revision data 

associated with the changes will be that of the operator at the time the Text to Tracking Button is pressed. 

MISC GROUP 

 

The Misc Group provides useful features that may be helpful to the operator during the Rule Drafting 

process.  This functionality is discussed below: 

Draft View Button 

The Draft View button displays the document in Draft View.  Draft view shows text formatting but 

simplifies the layout of the page so that you can type and edit quickly. In draft view, some page elements 

do not appear, such as the boundaries between pages, headers and footers, backgrounds, and pictures.  

Draft View is most useful when working with styles because the style associated with each paragraph is 

shown on the left hand side of the document. 

 

Print Layout Button 

The Print Layout button displays the document in print layout view.  This allows the operator to see the 

document as it appears on the printed page. Print layout view is the default view when you open a new 

document. 
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Split Rule Button 

It is often helpful to work on several rules in one document.  OAH requires that Rules be filed with OAH 

as individual Rule documents.  The Split Rule Button divides the currently displayed document into 

individual Rules.  The utility uses the History Note or Authority line to determine where a Rule ends.  It 

uses the Rule Citation to name the individual Rule document.  Rule range documents will be created if 

there are multiple rule citations with only one history note (as is often the case for repealed rules). The 

original document must be saved before you click the Split Rule button and the document must contain 

more than one Rule.  The original document is not modified. 

Show/Hide (Paragraph Mark) Button 

Pressing the Show/Hide button allows the non-printing characters to be revealed or shown in your 

document. "Nonprinting characters" is Word's term for anything that takes up space or has a formatting 

function but does not appear on the printed page, including spaces, tabs, page or paragraph breaks, etc.  

Showing the “Nonprinting characters” It is primarily used to be able to identify formatting or spacing 

issues in word processing documents.  This button allows the operator to quickly show or hide these 

characters. 

WORKING WITH DOCUMENTS CREATED BEFORE THE TEMPLATE WAS AVAILABLE 

To take advantage of the features available in the OAH Agency Rules Template for documents that were 

in the Rule Making Process prior to the implementation of the OAH Agency Rules Template, you must 

create a new document based on the Template and insert your existing document into the newly created 

document.  Although copy and paste will work, we recommend that you use the insert feature to include 

the contents of existing documents into your documents. 

Create a New Document based on the OAH Agency Rules Template 

Double click on the Template Icon on the Desktop.  A new document based on the template will be created.   

Insert existing Document 

Use the Insert Rule from File function described previously in this document to navigate to the location 

of your existing Rule document and insert that document into your newly created Template based 

document. 
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Appendix A 

 

Attaching the OAH Agency Rules Template to an Existing Document 
 

The OAH Agency Rules Template documentation suggests storing the OAH template on your desktop.  This works great in a 

single user environment.  However, many Rule Making Coordinators work in a collaborative environment. Each agency has 

their own recommendations and computer configurations.  That makes it difficult to recommend a solution that will work for 

all agencies.  The ideal setup in a multiuser environment would be to utilize Microsoft Words “WorkGroup” template feature.  

This requires that all user workstations have a single location specified as their “workgroup template location” and the OAH 

template be stored there.  This requires access to a common drive by all users and configuration of each user’s installation of 

Microsoft Word.  This may not be possible for all agencies. 

 

The biggest challenge in a multiuser environment is that when a document is opened, Word may not be able to correctly locate 

the OAH template since the template in not located consistently.  This is most common when Rule Making documents are 

emailed among users. When a document created with the OAH template is emailed, the template will not be attached when it 

reaches the Recipient. 

 

To Work around this issue, we are suggesting the following possible approaches. 

 You can create a new document using the OAH template stored on your computer and insert the contents of the 

document you received into new document.  Save that document and begin working. 

 If you would prefer not to create a new document, we have documented two options that you can utilize to attach the 

OAH Agency Rules Template to your document. 

o You can Attach the OAH template to your document using the Word Menu. 

o You can create a Macro and add the Macro to your Quick Access Toolbar. 

These two options are described below. 

 

NOTE: The OAH Agency Rules Template should only be used on documents that you know were 

originally created using the OAH Agency Rules Template.  Attaching the template to a document that 

was not created using the OAH Agency Template will most likely result in repeated errors being displayed 

while attempting to work on the document.  
 

 

Attaching the OAH Template to your Document using the Word Menu 

Enable the Developer Tab on the Word Ribbon 

You must first enable the Developer tab on the Word Ribbon before you can access the Template menu item in 

Microsoft Word.  The following steps only have to be performed once.  After you have enable the Developer Tab, you 

can go straight to the Attach Template instructions below.  Enabling the Developer Tab is accomplished as follows: 

1. Click on File on the Word Ribbon 

 
  

Click File 
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2. The File Menu will be displayed.  Select Options. 

 
 

3. The Word Options Menu will be displayed.  Click Customize Ribbon. 

 

4. The Customize “The Ribbon and Keyboard Shortcuts window” will be displayed.  Put a Checkmark in the 

Developer box in the right hand list box and click OK.  You will now have the Developer Tab on your Word 

Toolbar. 

  

Click Options 

Click 

Check Mark in Developer Box 
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Attach the OAH Agency Rule Template to your Document 

1. After you have access to the Developer Tab, attaching the OAH template is fairly straight forward.  You click on the 

Developer tab and click the Document Template Button. 

 
2. After you have access to the Developer Tab, attaching the OAH template is fairly straight forward.  You click on the 

Developer tab and click the Document Template Button.  The “Templates and Add-ins” window will be displayed.  

On that window, click the Attach Button. 

 

3. The “Attach Template” window will be displayed.  Navigate to the location on your computer where the document 

is stored and select the OAH Agency Rules Template.  Click Open. 

 

4. Click on the OK button when the “Templates and Add-Ins” window is displayed.  The OAH template is now 

attached to your document and you should see the OAH tab on the Microsoft Word window. 

  

Click 

Click 

Click 

Select 
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Creating a Macro to Attach the OAH Template to your Document 

1. Open Word with a Blank Document 

2. Click on the View Tab 

3. Click on the Macros Button 

4. Click on the View Macros Menu Item 

 

5. After Clicking the View Macros Menu Item, the Macros window will be displayed. 

a. Type AttachTemplate in the Macro name filed (No spaces) 

b. Click the Create Button 

 

6. After Clicking the Create Button the New Macros Window will be displayed: 

 

7. Copy or Type the following text into the macro as show above: 

ActiveDocument.AttachedTemplate = "YOUR FILE LOCATION" & "OAH Agency Rules Template.dotm" 

Replace YOUR FILE LOCATION with the file location where you stored the template.  For example, 

S:\Template\ 
You must have a backslash at the end of the file location. 

8. Click the X to Close the New Macros Window.  You have now created the macro that will attach the OAH template 

to your document.  

  

View Tab 

View Macros 

Create Button 

Type Here 

Type or Paste Macro Text Here 

Click X to close Macro 

Window 
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9. The next step is to add the macro to Words Quick Access Toolbar so that it will be easily available to you.  Click on 

the Customize Quick Access Toolbar Drop Down arrow on the right side of your Quick Access Toolbar: 

 

10. The Customize Quick Access Toolbar menu will be displayed.  Click More Commands. 

 

11. The Word Options Menu will be displayed: 

a. Click the More Commands Drop Down and Select Macros 

b. Click on the Attached Template Macro in the left hand list box and click the Add Button.  The macro will 

be added to the right hand list box.  Click the OK button to close the Word Options Window. 

 

12. The Macro will now be displayed on your Quick access toolbar.  If you do not see the OAH tab on your Word 

Toolbar, you can click the Macro Icon on your tool bar and the OAH template will be attached and the toolbar will 

be visible. 

 

Quick Access Toolbar 

Click 

Click 

Use Dropdown to select Macros 

Select 

Macro 
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February 7, 2019 17 

APPENDIX B – Rule Formatting 

There are three ways to format a rule. The format options are: 
1. Subdivided from the beginning 
2. Introductory paragraph with a listing 
3. Single paragraph 

The History Note will be formatted a little differently than the rule itself. 
 
NOTE: There are several styles that have been retired.  These styles are only valid for existing rules that already 
contain these styles.  They are SubPart, SubsubPart, SubItem Lvl 3, and SubItem Lvl 4.  These styles are noted 
with (HISTORICAL USE ONLY) in the tables below. 
 
The following tables provide formatting details for each rule style and the History Note: 

If a Rule is Subdivided from the Beginning, Use this Sequence: 

Style Rule Text 

Rule 01 NCAC 01 .1111 RULE NAME AND NUMBER IN BOLD AND ALL CAPS 
Paragraph (a)  This level in a rule is a Paragraph. You do not skip a line between the rule name/number 

and the beginning of this Paragraph. After typing the letter in parenthesis, it is followed with 2 
spaces. The first level of a rule (Paragraph) is the only time in a rule that the item in parenthesis 
is followed by 2 spaces instead of an tab. 

Subparagraph 
 
Subparagraph 

(1) This level in a rule is a Subparagraph. You do not skip a line between the 
Paragraph and Subparagraph. After typing the number in parenthesis, it is 
followed with 1 tab. 

(2) Remember – Any new level of a rule must have at least two items to create 
another subdivision. 

Part (A) This level in a rule is a Part. You do not skip a line between the 
Subparagraph and Part. After typing the letter in parenthesis, it is 
followed with 1 tab. 

SubPart (i) This level in a rule is a SubPart. (HISTORICAL RULES ONLY) 
SubsubPart (I) This level in a rule is a SubPart. (HISTORICAL RULES 

ONLY) 
Paragraph (b)  Return to the left margin for the next Paragraph. The text is flush with the left margin and 

no lines are skipped between the different sections of the rule. The parenthesis is followed by 
two spaces. 

If a Rule Contains an Introductory Paragraph with a Listing, Use this Sequence: 

Style Rule Text 

Rule 01 NCAC 02 .1111 RULE NAME AND NUMBER IN BOLD AND ALL CAPS 
Paragraph The opening paragraph is formatted with the text flush to the left margin and each consecutive 

line will wrap around to the left margin as shown here. 
Item 
 
Item 

(1) The first level in this type of format is called an Item. After typing the number in 
parenthesis, it is followed with 1 tab. 

(2) Remember – Any new level of a rule must have at least two items to create 
another subdivision. 

SubItem Lvl 1 (a) This next level in formatting this way is a Sub-Item. You do not skip a 
line between the Item and Sub-Item. After typing the letter in parenthesis, 
it is followed with 1 tab. 

SubItem Lvl 2 (i) This level in a rule is also called a Sub-Item. You do not skip a 
line between the different levels of Sub-Items. After typing the 
letter in parenthesis, it is followed with 1 tab. 

SubItem Lvl 3 (A) This level in a rule is also called a Sub-Item. 
(HISTORICAL RULES ONLY) 

SubItem Lvl 4 (I) This level in a rule is also called a Sub-Item. 
(HISTORICAL RULES ONLY) 

  



February 7, 2019 18 

If a Rule Contains a Single Paragraph, Use this Format: 

Style Rule Text 

Rule 01 NCAC 03 .1111 RULE NAME AND NUMBER IN BOLD AND ALL CAPS 
Paragraph A rule can be a single paragraph. Do not skip a line between the rule name/number and the first 

line of the paragraph. There are no subdivisions in this type of formatting. 

 

History Note Format: 

Style Rule Text 

History History Note: Authority [list in numerical order the citations to the agency's authority for the 
rule; all citations are separated by a semicolon; and the last citation also ends 
with a semicolon]; 

HistoryAfter Eff. [this is the effective date of the original adoption of the rule]; 
HistoryAfter Amended Eff. [these are amendment dates to the rule and shall be listed in 

chronological order, with the most recent amended date listed first]; 
HistoryAfter Temporary [Adoption][Amendment][Repeal] Eff. [Temporary rules are listed as 

a separate item]; 
HistoryAfter Repealed Eff. [If an agency deletes the rule in its entirety, this is a repeal. This 

rule number and history note can never be used again. 
NOTE: The most current effective date which is on the last line of the History Note, must be 

underlined completely if it is a new rule and if it is an adoption or repeal, then the new 
date must be the first shown and underlined 

 

Miscellaneous Format: 

Style Rule Text 

Chapter CHAPTER 01 - RULE CHAPTER NAME 
(Should always appear at the top of the first rule in a Chapter) 

SubChapter SUBCHAPTER 01A – RULE SUBCHAPTER NAME 
(Should always appear at the top of the first rule in a SubChapter) 

Section SECTION .0100 – RULE SECTION NAME 
(Should always appear at the top of the first rule in a Section) 

Base The Base style should be applied to any paragraph that does not meet the other styling 
guidelines outlined in the document.  The Base style is generally applied to blank lines, tables 
and forms.  

 


